NEO GEO MVS click of death

Qui trovi aiuto nella risoluzione dei problemi hardware del tuo cabinato
Rispondi
skylab
Gamer
Gamer
Messaggi: 41
Iscritto il: 18/05/2017, 14:46
Reputation: 0

NEO GEO MVS click of death

Messaggio da skylab » 24/04/2018, 15:56

Ciao a tutti. Ho acquistato una base neo geo ma non funziona, premetto che non sono un esperto di neogeo. Da una ricerca in rete dei sintomi sono risalito a quello che viene definito click of death. Sia con cartuccia che senza ottengo una garbage screen, leggermente diversa di volta in volta, non un’immagine fissa ma lampeggiante, con un tic tic veloce che si sente sugli altoparlanti (da qui click of death). Da quanto ho capito il problema è che non riesce a caricare il bios, ed effettivamente se rimuovo la mask rom fa la stessa identica cosa.
La scheda mi è stata venduta come funzionante al 100% con tanto di foto che ne provavano il funzionamento. È possibile che si sia danneggiata durante il trasporto? Magari il venditore è in buona fede.
Ho fatto diverse verifiche con l’oscilloscopio, il cristallo del 68k ha la giusta frequenza di 24MHz, sembra ok anche il circuito dell’orologio: il d4990 è alimentato e il cristallo ha una frequenza di 32.768 KHz.
Su tutti i pin del bios (A0-15 e D0-15) c’è un segnale, stessa cosa sui vari pin dei chip delle ram e sul 68k, sembra che ci sia comunicazione tra tutti i chip, questo segnali non ci sono senza bios. Ho verificato tutte le connessioni tra 68k, ram, mask rom come indicato qui e sono tutte ok. Il watchdog si può disabilitare ponticellando j2, ma si freeza e basta non va avanti. C’è qualcosa in particolare che devo verificare? Purtroppo non ho altre basi mvs o bios, quindi non so se il problema è nella scheda o più semplicemente sul bios.
PS il chip NEO-E0 scalda subito e parecchio, mentre tutti gli altri sono freddi, tranne il chip audio yamaha che diventa tiepido dopo un po', che sia lui guasto? In ogni caso non ha pin in corto e c'è attività su vari pin.


Avatar utente
Barito
Extreme Arcader
Extreme Arcader
Messaggi: 2496
Iscritto il: 08/12/2015, 19:18
Reputation: 636

Re: NEO GEO MVS click of death

Messaggio da Barito » 24/04/2018, 16:27

Il garbage screen è fisso, oppure come dicono nella wiki che hai linkato varia con una certa frequenza?
Dal ciglio della strada osservo sbraitando i lavori in corso nel mondo arcade...


skylab
Gamer
Gamer
Messaggi: 41
Iscritto il: 18/05/2017, 14:46
Reputation: 0

Re: NEO GEO MVS click of death

Messaggio da skylab » 24/04/2018, 18:05

No no come ho scritto "lampeggia" e si sente il click veloce sugli altoparlanti, proprio come nella wiki. Sempre nella wiki c'è un sample del suono, esattamente uguale a quello che sento io. Facendo il ponticello su j2 si disabilita il watchdog e di conseguenza il garbage si freeza e il click non si sente più. Da quanto ho capito qualsiasi mvs senza bios fa così.


Avatar utente
f205v
Site Admin
Site Admin
Messaggi: 5746
Iscritto il: 01/12/2015, 10:37
Reputation: 333
Località: Lugano
Nazione: Svizzera
Contatta:

Re: NEO GEO MVS click of death

Messaggio da f205v » 25/04/2018, 20:12

Io per prima cosa controllerei le RAM...
Immaginef205v


skylab
Gamer
Gamer
Messaggi: 41
Iscritto il: 18/05/2017, 14:46
Reputation: 0

Re: NEO GEO MVS click of death

Messaggio da skylab » 26/04/2018, 9:29

f205v ha scritto:
25/04/2018, 20:12
Io per prima cosa controllerei le RAM...
Ok ma come le controllo? le scambio di posizione? i collegamenti tra ram, bios e 68k sono tutti ok, verificati pin per pin.
Il chip marchiato NEO-E0 scalda subito e parecchio, è normale? Non ha pin in corto.


Avatar utente
Barito
Extreme Arcader
Extreme Arcader
Messaggi: 2496
Iscritto il: 08/12/2015, 19:18
Reputation: 636

Re: NEO GEO MVS click of death

Messaggio da Barito » 26/04/2018, 10:58

Dovresti procurarti un'altra base sicuramente funzionante e fare un po' di swap di componenti. Questa la via più semplice in mancanza di attrezzatura specifica.
Puoi comunque provare a verificare le solite cause di problemi, in particolare la tensione di alimentazione (i +5V).
Dal ciglio della strada osservo sbraitando i lavori in corso nel mondo arcade...


skylab
Gamer
Gamer
Messaggi: 41
Iscritto il: 18/05/2017, 14:46
Reputation: 0

Re: NEO GEO MVS click of death

Messaggio da skylab » 27/04/2018, 9:37

La tensione è ok, verificata anche sui vari componenti. Come dicevo ho fatto diverse verifiche con l'oscilloscopio, c'è segnale su tutti i pin del bios e del 68k, stessa cosa sulle ram tranne i pin 22 e 27 che stanno fissi su un valore alto, ma ho trovato qualcosa in rete e forse è normale durante il caricamento del bios. Questi pin infatti sono gli unici a non essere collegati al 68k.


Rispondi